Page tree
Skip to end of metadata
Go to start of metadata
  • Keine Zugriffsrechte auf das RapidClipse Verzeichnis - Installiern Sie RapidClipse in ein Verzeichnis, für das der angemeldete Nutzer alle Zugriffsrechte besitzt, oder starten Sie RapidClipse als Administrator.
  • Setup findet keine Java Runtime - Falls die Fehlermeldung Setup could not find a Java Rintime on your system erscheint, konnte keine Java 8 Runtime Environment auf Ihrem System gefunden werden. Wählen Sie im erscheinenden Dialog C: > Programme(x86) > Java > jre1.8.0_121 > bin aus und selektieren Sie java (Anwendung).
  • Internet-Anbindung nicht vorhanden oder zu langsam - Für den erstmaligen Start von RapidClipse brauchen Sie eine möglichst schnelle Internet-Verbindung, da RapidClipse alle benötigten Libraries via Maven downloaden muss.
  • Keine Internet-Verbindung
    • Proxy Einstellungen können Sie festlegen im Menü Windows > Preferences > General > Network Connections.
  • Verwendung von Sonderzeichen - Verwenden Sie für Verzeichnisnamen keine Sonderzeichen oder Umlaute, z.B. für den RapidClipse Installations-Ordner oder für den Workspace.
  • Kein Zugriff auf die mitgelieferte H2 Test-Datenbank - Geben Sie Port 5435 frei über Menü Windows > Preferences > XDEV > Sample Database. Falls Port 5435 bereits verwendet wird, stellen Sie diesen um.
  • Northwind H2 Test-Datenbank als Produktiv-Datenbank - Setzen Sie die Northwind Test-Datenbank nicht produktiv ein, da diese ausschließlich für Tests vorgesehen ist.
  • Aktivierte Snapshot Option - Die Option Use snapshot releases kann bei produktiven Projekten zu schweriegenden Fehlern führen und sollte deshalb deaktiviert werden. Wählen Sie im Menü Window > Preferences > RapidClipse Framework und deaktivieren Sie die Checkbox Use snapshot releases.
  • Ein Workspace für verschiedene RapidClipse Versionen - Jede RapidClipse Version benötigt ihren eigenen Workspace. Die Nutzung eines Workspaces durch mehrere RapidClipse Versionen führt unweigerlich zu Fehlern. Definieren Sie beim Starten von RapidClipse einen neuen Workspace. 
  • Workspace auf Netzlaufwerk - Legen Sie Ihren Workspace nicht auf einem Netzlaufwerk ab.
  • Dateien im Workspace editiert oder gelöscht - Editieren oder Löschen Sie keine Dateien im Workspace manuell.
  • Copy&Paste im Project Management - Verwenden Sie im Project Management kein Copy&Paste, sondern besser Drag&Drop oder die Refactoring Funktion, die Sie über Kontextmenü > Refactor aufrufen.
  • Entity- und Datenbankstruktur nicht identisch - Wenn Sie Änderungen an Ihren Datenbanktabellen vornehmen, müssen auch die entsprechenden Entities aktualisiert werden, und umgekehrt. Es ist deshalb empfehlenswert, für die Entity-Generierung immer die gesamte Datenbank zu importieren (Datenbank > Entity Import). Wenn Sie nur für Teile Ihrer Datenbank Entities generieren lassen, können zu später generierten Entities keine Relationen mehr hergestellt werden.
  • Änderungen während der Vorschau - Während der laufenden Preview im Browser sollten Sie weder Änderungen an Ihrem Code oder an Ihrer Projektstruktur, noch Maven Updates durchführen, da das Betriebssystem während der Vorschau den schreibenden Zugriff auf einzelne Dateien blockieren kann, die von der lokalen Vorschau-Instanz verwendet werden. Als Folge kann es zu schwerwiegenden Inkonsistenzen in Ihrem Code kommen. Änderungen im GUI-Builder bei laufender Vorschau sind dagegen unproblematisch.
  • Update nicht korrekt ausgeführt 
    • RapidClipse IDE - Wählen Sie im Menü Help > Check for Updates.
    • RapidClipse Framework - Wählen Sie im Menü Help > Check for Framework Updates.
    • Eigenes Projekt updaten - Klicken Sie Ihr Projekt im Project Management mit Rechtsklick an und wählen Sie im folgenden Kontextmenü Maven > Update Project. Dadurch werden Maven Dependencies, Projekt-Konfigurationen und Workspace Resourcen aktualisiert und damit verbundene Probleme behoben.  

    • Andere Eclipse Plugins - Nach einem RapidClipse Update sollten Sie für zusätzlich installierte Eclipse Plugins, z.B. JasperReports, immer auf die Kompatibilität prüfen.
  • Kein, kein aktuelles, oder falsches Java Development Kit (JDK) vorhanden - Um Projekte deployen zu können, muss ein JDK ab Java Version 8 Update 121 auf Ihrem Rechner verfügbar und in RapidClipse eingebunden sein. Die JDK 8 64-bit Version können Sie nur mit einem 64-bit Betriebssystem verwenden.

Maßnahmen bei Fehler

Fehler in der RapidClipse IDE allgemein

  • Internet-Verbindung - Prüfen Sie, ob eine Internetverbindung besteht.
  • Workspace wechseln - Wechseln Sie Ihren Workspace.
  • Neustart - Starten Sie RapidClipse neu und warten Sie ab, bis sämtliche Dependencies geladen wurden.
  • .m2 Ordner löschen - In Ausnahmefällen können Sie den .m2 Ordner in Ihrem User Home Verzeichnis löschen. Anschlißend müssen Sie ein Maven Update durchführen, um alle nötigen Dependencies neu zu laden.

Fehler im Code

  • Plötzlich auftretende Fehler im Code-Editor
    • Projekt cleanen - Wählen Sie im Menü Project > Clean.
    • Projekt updaten - Klicken Sie Ihr Projekt im Project Management mit Rechtsklick an und wählen Sie im folgenden Kontextmenü Maven > Update Project
    • View Problems öffnen - Die Eclipse View Problems listet sämtliche, aktuell bestehende Probleme auf mit hilfreichen Hinweisen auf die Fehlerstelle, -art und -ursache.
  • Debugger - Der Debugger ist ein Tool zum Auffinden von Fehlern in Ihrem Quellcode. Damit können Sie Ihren Code Zeile für Zeile oder gezielt bis zu einem bestimmten Haltepunkt ablaufen lassen und dabei sämtliche in der Anwendung verarbeitete Werte überwachen. Dadurch lassen sich Fehler im Code sehr viel leichter aufspüren. 

Fehler im GUI-Builder

  • GUI-Builder reagiert nicht mehr oder aktualisiert sich nicht
    • Refresh - Klicken Sie im GUI-Builder auf , um einen Refresh des GUI-Builders durchzuführen. 
    • GUI-Builder schließen und neu öffnen 
  • No labels