Most Frequent Errors

  • No access rights for the RapidClipse directory - Install RapidClipse into a directory for which you have full access rights, or start RapidClipse as an administrator.
  • Setup could not find a Java Runtime on your system - If you get the error Setup could not find a Java Runtime on your system, no Java 8 Runtime Environment could be detected on your system. In the following dialog, select C: > Programme(x86) > Java > jre1.8.0_121 > bin and choose java (application).
  • Internet connection not available or too slow - For the initial startup of RapidClipse, you need the fastest possible Internet connection because RapidClipse will download all required libraries via Maven.
  • No Internet connection
    • Proxy settings can be changed in the menu Windows> Preferences> General> Network Connections.
  • Use of special characters - Do not use special characters for folder names, e.g. for the RapidClipse installation folder or the workspace.
  • No access to the supplied H2 test database - Release port 5435 by selecting Windows> Preferences> XDEV> Sample Database in the menu. If port 5435 is already in use, change the port settings.
  • Using the Northwind H2 test database as a productive database - Do not use the Northwind Test database for productive use. It is for testing purposes only.
  • Snapshot option enabled - In productive projects, the option Use snapshot releases can lead to major errors. As such, you should disable it. To do so, select Window > Preferences > RapidClipse Framework in the menu and deselect the Use snapshot releases checkbox.
  • A workspace for different RapidClipse versions: Each RapidClipse version requires its own workspace. If you attempt to use the same workspace with several RapidClipse versions, this will inevitably lead to errors. Define a new workspace every time you start a new RapidClipse.
  • Workspace network drive - Do not deposit your workspace on a network drive.
  • Editing or deleting files in the workspace - Do not manually edit or delete any files in the workspace.
  • Copy and paste in Project Management - Do not use the copy and paste commands in Project Management; instead, use drag and drop or the refactoring function, which you can find in the Context menu > Refactor.
  • Entity and database structures are not identical - If you make changes to your database tables, you will need to update all related entities, and vice versa. As such, we recommend that you always import the entire database for entity generation (Database > Entity Import). If you only generate the entities for part of your database, you will be unable to establish relations to entities that are generated at a later date.
  • Changes during the preview - During the preview, the operating system can block the write access to the individual files used by the local preview instance. This can lead to serious inconsistencies in your code. As such, while running the preview in your browser, you should not make any changes to your code or project structure and should not perform any Maven updates. However, you can make changes in the GUI Builder during the preview because these will not cause any problems.
  • Update is not running properly 
    • RapidClipse IDE - Choose Help > Check for Updates in the menu.
    • RapidClipse Framework - Select Help > Check for Framework Updates in the menu.
    • Eigenes Projekt updaten - Under Project Management, right-click on your project and then select Maven > Update Project in the following context menu. Thus, all Maven dependencies, project configurations and workspace resources are updated and related problems are solved.  

    • Other Eclipse plugins - After a RapidClipse update, you should always check the compatibility of any additional Eclipse plugins you have installed, e.g. JasperReports.
  • No, no current, or wrong Java Development Kit (JDK) available - To deploy projects, a JDK 8 Update 121 or later should be available on your computer and integrated into RapidClipse. The 64-bit version of JDK 8 can only be used with a 64-bit operating system.

Troubleshooting

Errors in the RapidClipse IDE in general

  • Internet connection - Check the Internet connection.
  • Switch Workspace - Change your workspace.
  • Restart - Restart RapidClipse and then wait until all dependencies have loaded.
  • Delete .m2 folder - In exceptional cases, you can delete the .m2 folder in your user home directory. After doing so, you will need to perform a Maven update to reload all the necessary dependencies.

Errors in the code

  • Sudden errors in the code editor
    • Clean your project - Select Project> Clean in the menu.
    • Project update - Right-click your project in the Project Management and select Maven>Update Project in the following context menu.
    • Open the problems view - The Eclipse View Problems lists all current problems together with helpful hints on the error location, type, and cause.
  • Debugger - The debugger is a useful tool that can help you to find bugs in your source code. It allows you to run your code line by line, or to deliberately run it up to a certain breakpoint while monitoring all values processed in the application. This allows you to find errors in the code more easily.

Errors in the GUI Builder

  • GUI Builder does not respond or refresh
    • Refresh - Click on  in the GUI Builder to refresh.
    • Close the GUI Builder and reopen