Charts

Vorrausetzungen

Zur Entwicklungszeit:

  • RapidClipse IDE ab Version 10.2
  • RapidClipse Framework ab Version 10.2
  • Eingebundene Dependency

    <dependency>
    	<groupId>com.rapidclipse</groupId>
    	<artifactId>rap-server-charts</artifactId>
    	<version>10.02.00-RAP-GA</version>
    </dependency>
  • Google API Key für XdevMap- und XdevGeoChart

Zur Laufzeit:

  • Eine bestehende Internetverbindung da die Charts über die Google API gerendert werden müssen.

Umfang der Charts

Die RapidClipse Charts sind eine Teilimplementierung der Google Charts welche in die Vaadin Umgebung eingebettet wurden. Im ersten Schritt wurden nachfolgende Charts implementiert:

Funktionsumfang